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by Jörg Rapp (University Koblenz-Landau)

 1 Introduction

With the help of this tutorial the user should be able to create a html presentation with 
audio stream based on a Powerpoint presentation. This manual is structured into XX parts.
In the first part, the installation of necessary software tools is described, the second part 
gives a step by step tutorial how to create a html presentation.

 2 Necessary software and its installation

• A software to create and edit presentations and to export them into PDF format: e.g.
Microsoft Powerpoint, LibreOffice Impress or OpenOffice Impress.

• If presentations with interactive elements or animations are used an addon tool to 
split animated slides into single slides, e.g. PPspliT 

• A tool, that converts PDFs into single images and creates a html file, e.g. 
PanDocElectron and additionally required software tools.

• Software to record audiostreams for the slides, e.g. Audacity

 2.1 Installation

 2.1.1 Installation of presentation software

We assume, that the user has a installed version of a presentation software, e.g. Microsoft
Powerpoint, LibreOffice Impress or OpenOffice Impress.
If not, you can download LibreOffice or OpenOffice software package for free from the 
following URLs:
OpenOffice: https://www.openoffice.org/download/index.html
LibreOffice: http://www.libreoffice.org/download/libreoffice-fresh/?version=5.2.0

Please select the installation files for your operating system, download them and follow the
installation instructions.

 2.1.2 Installation of software for splitting animated presentations

First the powerpoint presentation is converted into a static pdf. Standard presentation 
software like Microsoft Powerpoint, LibreOffice Impress or OpenOffice Impress is abel to 
export static presentation files without animations into a pdf. Each single slide is exported 

https://www.openoffice.org/download/index.html
http://www.libreoffice.org/download/libreoffice-fresh/?version=5.2.0


as an image.
The mentioned presentation software is not able to export slides with animated elements, 
e.g., if parts of a slide are only visualized by a given action, e.g. by pressing a button. If 
animated slides are used they have to be converted into single slides with each animated 
step on a single slide with a add-on.

Microsoft Office

• Follow the URL http://www.dia.uniroma3.it/~rimondin/downloads.php , download the
installer for PPspliT and follow the install instructions.

OpenOffice and LibreOffice

• Download the following file 
https://raw.github.com/monperrus/ExpandAnimations/master/dist/ExpandAnimation
s-0.4.oxt   and open it with LibreOffice or OpenOffice. 

A addon will be installed for OpenOffice/ Libre Office impress, which helps to convert 
animated slides in more than one slide with each animation step on a single slide.

 2.1.3 Installation of converter Software

We will use the software tool PanDocElectron together with additional software tools to 
convert the generated PDF file into a html presentation. PanDoc is able to use different 
input formats, however, at the moment only conversion from pdf to audioslides is tested 
and works fine.

• To install PanDoc and necessary additional software please visit 
http://niebert.github.io/PanDocElectron/ and follow the installation manual described
for your Operating System. 

As mentioned, additional software is necessary to get PanDoc run. It might be the case, 
that some of the additional software tools are installed yet. Please check the version of the
installed software tools. If necessary, update the versions according to the install manual.

 2.1.4 Installation of Audio recording Software

We recommend to use the audio recording software audacity. Audacity supports Linux, 
Windows and OS X and can be downloaded free of charge.

• Go to the download page http://www.audacityteam.org/download/ and download the
appropriate version for your operating system and follow the installation 
instructions.

http://www.audacityteam.org/download/
http://niebert.github.io/PanDocElectron/
https://raw.github.com/monperrus/ExpandAnimations/master/dist/ExpandAnimations-0.4.oxt
https://raw.github.com/monperrus/ExpandAnimations/master/dist/ExpandAnimations-0.4.oxt
http://www.dia.uniroma3.it/~rimondin/downloads.php


 3 Tutorial: Creation of a HTML presentation

 3.1 Creation of a PDF

 3.1.1 Microsoft Office users 

Microsoft Office users with presentations without animations

Please follow this steps, if you use Microsoft Office and if your presentation has only static 
slides

• Load your presentation into Microsoft powerpoint (File → Open → select your file).

• Export the presentation as a PDF (File → Export → PDF/XPS export) 

Microsoft Office users with animated presentations

Please follow this steps, if you use Microsoft Office and if your presentation has also 
animated slides (e.g. contents appear after pressing a button).
By a standard export of a ppt file containing animated slides into pdf, only the „full“ slide 
without animation steps would appear in the exported PDF. To have all steps of the 
animated slide each in a single slide, we have to use the addon PPspliT.

• Load your presentation into Microsoft powerpoint (File → Open → select your file).

• In the Microsoft PowerPoint menue select the rider „PPsplit“. 

• Press the Button „Split animations“ (The checkbox „Split on click-triggered 
animations“ has to be activated). 

 



As a result you will get each on click-triggered animation step on a single slide. 

• Export the presentation as a PDF (File → Export → PDF/XPS export) 

 3.1.2 LibreOffice / OpenOffice users

LibreOffice / OpenOffice users with presentations without animations

Please follow this steps, if you use LibreOffice or OpenOffice and if your presentation has 
only static slides

• Load your presentation into LibreOffice / OpenOffice Impress (File → Open → 
select your file).

• Export it as a PDF: (File → Export as PDF ….),  press the „Export“ Button and 
select a folder in which you want to save your PDF

LibreOffice / OpenOffice users with animated presentations

Please follow this steps, if you use LibreOffice or OpenOffice and if your presentation has 
also animated slides (e.g. contents appear after pressing a button).
By a standard export of a ppt file containing animated slides into pdf, only the „full“ slide 
without animation steps would appear in the exported PDF. To have all steps of the 
animated slide each in a single slide, we have to use a addon.

• Load your presentation into LibreOffice / OpenOffice Impress (File → Open → 
select your file).

• In the bar menu select Tools → Add ons → Expand animations



After executing this command you will find 2 new documents in the folder, in which the 
original presentation is stored, one pdf and one odp file, both with the filename supplement
„expanded“. Both contain slides with each on click-triggered animation step on a single 
slide. 

 3.2 Conversion from PDF into a html presentation

For this step we will use mainly the softwaretool PanDocElectron. The softwaretools 
additionally installed work in the background and don‘t have to be used actively.

 3.2.1 Start PanDocElectron

Linux: 

• Open the terminal (e.g. with the command Ctrl+Alt+t)

• Change to the folder in which you have installed PanDocElectron (e.g. 
~/Documents/PanDocElectron )

• In the terminal execute the command „npm start“

Windows:

• Open the prompt: Windows 10: Windows + X, in the menu you can find the prompt 
(Eingabeaufforderung), execute it



• Change to the PanDocElectron folder: e.g. cd User/Documents/PanDocElectron

• Execute the following command in the prompt shell: „npm start“

Mac:

• Open the terminal

• Change to the folder in which you have installed PanDocElectron (e.g. 
~/Documents/PanDocElectron )

• In the terminal execute the command „npm start“

 3.2.2 Create a new project

After PanDocElectron has started, first create a new project. 

• Select „New“ in the menu bar

Choose a name for the project and a input format. In this tutorial we want to convert a pdf 
into a HTML audioslide presentation. 



• Input the project name

• Select „PDF Input for AudioSlides Output“. 

The project name determines the name of the folder the html file will be safed in. All output
files are safed in this subfolder, in which PanDoc was installed. 

• Press the „Create Project“ button.

Creating a new project means that a folder in your PanDoc folder is created, named with 
the project name. This folder contains 4 subfolders. Their meaning and contents are 
explained later.

 3.2.3 Conversion from PDF into HTML

• Open your filemanager and copy the PDF file you want to convert into the project 
folder. 

Switch back to PanDocElectron and press the „Convert“ button in the menu bar.

• Select the input file you want to convert (PDF)



It is important, that all file names (also the input files) don't contain special characters or 
empty spaces. If your input file name contains special characters or empty spaces please 
rename it.
In PanDocElectron, there are different parameters and settings, which are only important if
the input and output format are different to ours. Therefore, I will not explain them further. 
Important parameters are „AudioSlide Count“, „PDF Startpage“ and the checkbox „show 
Audio player“.
The parameter „AudioSlide Count“ determines, how many slides should be converted into 
a image file. Which value has to be entered into the field „PDF Startpage“ is dependent on 
the software you have used to create your PDF. Some softwaretools index the first page in
a PDF as slide 0, some as slide 1. You have to try out if your first slide is indexed with 0 or 
1. First try it with 0. Check the images in your project folder (in this example you can find 
the slide images in the folder /home/joerg/Documents/PanDocElectron/Ecotox1/images).

With the checkbox „show Audio player“ you can select if the audioplayer is displayed in the
HTML presentation or not. Displaying the player has the advantage, that the audiostream 
can be paused, forwarded etc. during watching the HTML presentation.

• Check if input and output format are right (Input format: „PDF Input for Audioslide 
Output“ , Output format: „Audioslides from PDF“)

• Enter the right values for „AudioSlide Count“, „PDF Startpage“ and the checkbox 
„show Audio player“

• To convert the PDF, press the blue „Convert“ button. You will receive some 



messages, e.g. where the converted images are stored, how to name the audios 
etc.

After the conversion you can find a HTML file in your projectfolder as well as the slides 
converted into image files in your „image“ subfolder.

Page Counter:
The PDF document may contain more slides/pages (assuming that PDF begins with the 
page number 0 (title pages) and ends with page number 15 (i.e. 16 pages). Adjust with 
setting according to your PDF.

Example: The PDF ecotox1.pdf contains 100 pages beginning with page 1 and 
you want to extract 10 slides/pages beginning from page 20 set the following 
parameters:

• Audio Slide Count: [10]
• PDF Startpage: [21]

This setting extracts the PDF pages 21,22, … ,29, 30. The created images of each 
slide are PNG files starting with img0.png, img1.img, … img9.img

So far, you have created a HTML file together with the related images. If you want you can 
try if the HTML file works. Doubble click on it. It should be opened in your browser. By 
pressing the arrow keys you can navigate through your presentation without audio 
streams.



 3.3 Audiorecording

In this program the audio-stream for the slides are created. In this tutorial the software tool 
Audacity is used. After starting Audacity, the following window appears.

With Button A you can start your audio record, with button B you can stop it. Before 
recording, it is necessary to adjust some settings.



 3.3.1 Selection of input device

First, the input device (microphone) which should be used, must be selected. The input 
device can be selected in the dropdown menu. Be sure, that the microphone was plugged 
in before starting audacity. Otherwise, the microphone will not be displayed in the 
dropdown menu. The project rate should be at 44100 Hz.

 3.3.2 Adjusting the input level

Before starting the record, the input level of the selected device must be adjusted. The 
input level is only displayed during a recording session and must be adjusted in a test 
record. 
Press button A to start the record and speak some text with the volume and distance from 
microphone, you will use for your final slide record. Adjust the input level device to a value,
with peaks that are not in the red area. The input level should also be not too low. After 
adjusting the input level, you can start with recording the slide text.

A: Start 
recording

B: Stop 
recording

Selection of 
Input device

Adjusting the 
input level

Input level

Project
rate



 3.3.3 Recording the slide text

There are two ways for recording the slide text. You can record the whole text of your 
presentation in one and cut it into parts according to the slides the text belongs to or you 
can record the text for each slide separately. 
For post-processing, we need in each record about 2 seconds with only background noise.
You can make a short break during speaking the slide text or record the background noise 
at the start or end of the audiostream and mark or remove it later. 

Recording:

• press the record button A and speak the slide text into the microphone. 

• to stop the record press button B.

• after recording the whole text safe the project (File → Safe project as). 

Noise Reduction:

• left click with your mouse on the starting point, hold the left button and select the 
part of the record with only background noise

• execute the noise reduction tool (Effect → Noise Reduction …)

• press the Get Noise profile button. The window will close.

• Select the whole audiostream in the spectrum window

• execute the command Repeat Noise Reduction (Effect → Repeat Noise Reduction)

The small waves in the spectrum window representing background noise disappear.
After post-processing, cut the audiostream into single parts, according to the slides they 
belong to. 

• note starting and ending time of the parts of the audiostream and the slide number 
they belong to. 

Select the part of the audiofile you want to use for a slide. You can select parts of a 
audiostream within the window displaying the spectrum of your record.
 



• Left click with your mouse on the starting point, hold the left button and select the 
part of the audio file you want to export. 

• The selected part can then be exported (File → Export selected Audio). 

• Select a name according to the following convention: „audio“+Slidenumber+“.mp3“, 

E.g. your audiostream for slide 1 should be named as „audio1.mp3“. Be aware, that the 
most converted slides start with slide number 0.

• Save the MP3 files in the audio folder of your project (e.g. 
/home/joerg/Documents/PanDocElectron/Ecotox1/audio) . 

Use the following settings: Quality: 220 – 260 kbps; Variable Speed: Standard

• Repeat the described steps (select and export) for each slide.

It is also possible to record each slide separately. For each slide a new session must be 
started (File → New). The mp3s can be directly exported without selection of parts (File →
Export Audio). However, the postprocessing steps have to be performed for each slide. 

Sometimes an additional audio codec must be installed (Lame and FFMpeg). You will 
receive a message, that they are missing, before you can safe the MP3 files. Follow the 



download instructions and download the codec and install it.

You can find the created HTML file in the project folder (e.g. 
/home/joerg/Documents/PanDocElectron/Ecotox1 ). Open it and try if the 
presentation works and if the audiofiles are played at the right slide.
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